SAFARI General Instructions

Open Excel.

Click on the Data Tab.

Click on “From Other Sources”.
Select “From Miscrosoft Query”.
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into Excel as a Table or PivotTable report. L
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= Create a connection to a SQL Server Analysis Services cube.

= Import data into Excel as a Table or PivotTable report. L

o From XML Data Import

= S pen or map a XML file into Excel.

= o From Data Connection Wizand L
=i Import data for an unlisted format by using the Data
= Connection Wizard and OLEDB.

0@ 0w

e From Microsoft Queny i )
ﬁi j::‘z“._?e-:;tug?zt:::rua' ::; ;r;;éed Farmat by using the hdicrosoft |:
Select the Database you would like to pull from:

pe
Choose Data Scurce u

Databaszes I Queries I OLAF Cubes I
<Mews Data Source:

dBASE Files™ _ Cancel |
ElS*

Encel Files” Browse... I
MS Access Databasze™

Safar_Connection™ Options... I
S afari_Connection™

LSAS™ Delete I

E‘I W Use the Queny Wizard to createfedit queries

Insert your Reflections Password in the “Password” field.
Click “OK”.
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A popup will display while searching for the data source (Reflections).

[=4] .
g E Connecting to data zource. ..




Once connected, you can select the data you want to use.
Open up the table (by clicking on the + sign beside the name) to see the selections.
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Example of Table view:
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Once data is pulled over, you can place your entries into the order that you want to see the columns by
using the up & down arrows.
Once columns are arranged, you can select “Next” to move to the next screen.
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All data in Reflections is pulled unless you filter the query.
If you only want to see active jobs, then you pull in the job_status and set the filter to 1.
In Reflections, a job status of 1 = active.

Other possible filters would include Start and Stop dates.

All data must be reviewed when it gets to Excel.

Click on “Next” to continue.
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Filter the data to specify which rows o include in pour querny.
If pou don't weant ta filker the data, click Hest.
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Data within the columns can be sorted on this Query Wizard — Sort Order screen.
This step is optional.
Click on “Next” to continue.
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Optional Step:

At this point, you can save your query if you will be using it again.
Click on “Save Query”.
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Optional: Can save query
for future use.

=zl = Back | Finish | Cancel
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A “Save As” box appears.

Give the query a name you will remember for future use.
Save on your computer.
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A query icon will be placed on your computer.
The query icon will look like this:

The next time you want to activate the search, double click on the query icon. Excel will open.
You may see a Microsoft Security Notice. Click “Enable” to get to the login screen.

Microsoft Office Excel Security Motice ? £

@ Microsoft Office has identified a potential security concern.

File Path: C:\Users\manchester. OHIO \Deskbop\Emis Flags.dgy

Data connections have been blocked. If you choose to enable data
connections, your computer may no longer be secure. Do not enable this

content unless you trust the source of this file.
[ Enable [ Disable

Insert your Reflections password & click OK.
The query that you previously saved will display with current information.




Click on “Finish”.

Query Wizard - Finish
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The “Import Data” popup will display. It will default to placing the information in the first cell of column

A unless you select another area.
Click “OK” to continue.
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Where do you want to put the data?
@) Existing worksheet:

() New worksheet \

ERs

Select how you want to view this data in your workbook.

Properties. .. [ Ok ] [ Cancel

The data will populate the worksheet.

The columns will display in the sort order that you set up in the Query Wizard.
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To add more information to the spreadsheet:
Open the query by double clicking. You may see a Security notice — select “Enable”.

Microsoft Office Excel Security Motice ? 2

@ Microsoft Office has identified a potential security concern.

File Path: C:WUsers

4 Data connections have been blocked. If you choose to enable data
- “'g connections, your computer may no longer be secure. Do not enable this
E content unless you trust the source of this file,

N ! —— | Enable Disable
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A login will appear. Type in your Reflections password & hit enter. The information will populate the
spreadsheet.

Click on the “Data” tab.
Click on the arrow under “Refresh All” to open a drop down window.
Select “Connection Properties”.
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Connection Properties...

Select the “Definition” tab & click the “Edit Query” button.
| Connection Propertsies L B | eS|

Connecton name: Vendor Query

Descripton:
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[ usage | Defmaon | |

Conmnecton type: Database Query
Connec Hor Hle: Cisersy Browse. ..
[ Arwaws use connecton file

Connecton strina:

[ Sawe password

Command tvpe: =18
Command et SELECT VEMNDORS  WEMNDHOR MO, VEMNDORS  FAME_ —
1, VEMNDORS.MAME_2, VEMNDORS. ADDRESS 1, = |
VEMNDORS. ADDRESS__2, VENDORS . CITY, =
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[ =TS ] [ ==t ]

You may see a Microsoft Query message:

MMicrosoft Queny

L\ This querny cannot be edited by the Query YWizard.
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Click OK.



The query will appear in Microsoft Query format.
Put your cursor in the last column heading & a drop down arrow will appear. Click on the arrow to
display additional records. Select columns to add.
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Select File>Return Data to Microsoft Office Excel
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Click “OK” in the Connection Properties box

Conmnnecticon Properties I

Conmnnecton name: vendor Query

Description:

Usage

Connection type:

Definiton

Database Query

CrUsersY

Connection file:

Browse. ..

[ always use connecton file

Connection string:

e

[ sawve password

Command type:

Command text:

Excel Serwvices:

sqQL

SELECT VEMDORS,. VENDOR_MNO, VEMNDORS . MAME_
1, VEMNDORS.MAME_2, YVEMNDORS. ADDRESS_1,
VEMDORS, ADDRESS_2, VEMNDORS.CITY,
VWEMNDORS.STATE, VEMNDORS. ZIP_CODE,

1
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Edit Query. ..

[ Export Connection File... . ]

Ty ] [

(=109 Cancel ]

You will get a warning message. Click “Yes”.

e
Microsoft Office Excel

S

The connection in this workbook will no longer be identical to the connection defined in the external file located at 'C: \Users\manchester. OHIO\Desktop\Wendor Query.dagy'.
The link to that external file will also be removed,
Do you want to proceed with changes to the connection in this workbook?

N

Yes

Wasg this information helpful?




A login prompt will display. Login using your Reflections credentials & click “OK”. The query will go out
and find the new information and add it to the existing query. If any other changes had been made to
fields on the spreadsheet, the new information\_/vould populate.
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Password |
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EXCEL TIPS

To Filter:

The columns are set to “Filter”. Look for the down arrow at the end of each column heading.
Click on the column you would like to filter.

All data will be selected (i.e. “Select All).

You can uncheck that box & select the items you are looking for.

Click “OK” to display the filtered data.
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To Sort:

Put the cursor in the top box of the column that you want to sort. Click on Sort A to Z. The column and
all of the information connected to it will sort as requested.
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To Highlight all:
Click the “Global Selector” button or Press CTRL + A.
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To Auto Adjust Column Width:
Once highlighted, you can auto adjust every column by double clicking on the line between the columns.
You will see an icon like this:'
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Once you see the icon, you are on the line. Double click & the column will expand to your longest entry.

To Copy:
Highlight the area that you want to copy. Right click on the mouse & select “Copy” from the drop down
or click on the copy icon or

click CTRL + C.
4 | Cut -
Ex | copy oz 'E%
8, Paste .[ - Home Insert Page Layout
Paste Special... (= * =
| _BI libri 11 || A
B EE
Delete Paste ¥ (B I U -8 |5~ é
Clear Contents -
i =
SF | Format Cells... Clipboard = Font
Row Height... Copy (Ctrl+C)
EIidE ZI { Copythe selection and put it on
Unhide the Clipboard.
orl NN EY] P or CTRL +C

The area that is about to copy will have “dancing” dash marks around it.
Select the next tab & paste the data into it.
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M 4 » »| Sheetl ~Sheet2 ﬁeta ]

To Paste:
Put your cursor in the cell that you want to copy the data into. Right click on the mouse & select “Paste”
or click on the Paste icon or

Click CTRL+V
Y Cut
== Copy 9 ‘* Calibri
55, | Paste — ==
bocte . Used when Ipa.ftelj [ S T
aste Specia .*""" . -yt
] formatting is in | = | Paste
Insert Copied Cells place 1 Formulas
Delete i Paste Values
Clear Contents Mo Borders
7| Format Cells...
Eow Height...
- & [F =] Paste Special...
Hide
Unhide oril =8l | As Picture * lorCTRL+V

To Rename Tabs:
Double click on the Sheet name to highlight the area. Once it turns black, type in the new name.
M4 r M Sheet? - Sheet3




To Split Screen Horizontally:
Click on the minus sign to the right & pull it down below the column heading line.
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o
The cursor will change to: . 7¥4. Pull down to split the screen.

To Split Screen Vertically:
Click on the thin bar at the bottom right corner & pull to the left.

i! The cursor will change to: .ﬂ" . Pull to the left to split the screen.

To Undo Split Screen:
Double click on the line that splits the screens.
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To Zoom In or Out:
In the bottom left corner, view size can be manipulated by sliding the cursor to left or right.

To Sum Column:

Click on column letter to highlight the column.
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On the “Home” tab, click on “AutoSum”. The totals will drop to the bottom of the column.

= AutoSum - ? [ﬁ

Fill -
Ij Sort & Find &
<2 Clear ~ Filter ~ Select ~

Editing

To Create Leading Zeros:

Right click on the column letter & select “Format Cells”.

On the “Number” tab, select “Custom”.

Put your cursor in the box where “General” is and erase that entry.

Insert zeros for each character in the cell. (Exp: IRN = 6 characters. Insert 6 zeros). Click “OK”

MNumber | Alignment I Font I Border I
Category: Important: Once saved — do not reopen.
General " Sample . . . . .
el B MO If the file is reopened, this formatting is lost
Currency - i "
prpsbiplt i Type: Vs and will need to be re-formatted.
Date
Tine 000000
Percentags The zeros will be placed at the beginning.
r_actlc_:n
Saenufic 1 would appear as 000001
ext

SEecial




FIELD DEFINITIONS

SSDT documentation can be found at:

http://ssdt.oecn.ki12.0h.us/

Select the Documentation Tab:

State Software De

Projects Documentation

Select USAS or USPS Select the USAS or USPS User Guide
Docurmentation
=Lil= Foslmzs USAS - Uniform
OECN Packages
Manuals
USAS -
A USAS User Guide
SAAS or
j’E‘i'“”_'SI USPS - Uniform
Wire b SOaS P USPS User Guide
In USAS, select the User Guide. In USPS, select USPS Useful Procedures.
* User Guide Section
* USAS User Guide » USPS Useful F’rocedugs

Select the Field Definitions at the bottom of the list:

» Field Definitions for UDMS-SAFARI ODBC

These documents define the fields that are available in each table.
Selections during each query must be made from one table at a time.
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